R1#sh running-config
!
no aaa new-model
memory-size iomem 5
!
!
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
half-duplex
!
!
interface Serial1/1
ip address 12.12.12.1 255.255.255.0
serial restart-delay 0
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
R2#sh running-config
!
aaa new-model
!
!
aaa authentication login noacs line none
aaa authentication login remote local
aaa authorization network remote local
!
!
username ipsecuser password 0 cisco
!
crypto isakmp policy 10
hash md5
authentication pre-share
group 2
!
crypto isakmp client configuration group ipsecgroup
key cisco
pool ippool
crypto isakmp profile cisco
match identity group ipsecgroup
client authentication list remote
isakmp authorization list remote
client configuration address respond
!
!
crypto ipsec transform-set cisco esp-des esp-md5-hmac
!
crypto dynamic-map cisco 10
set transform-set cisco
set isakmp-profile cisco
reverse-route
!
!
crypto map cisco 10 ipsec-isakmp dynamic cisco
!
!
interface Serial1/0
ip address 12.12.12.2 255.255.255.0
serial restart-delay 0
crypto map cisco
!
interface Serial1/1
ip address 23.23.23.2 255.255.255.0
!
ip local pool ippool 123.1.1.1
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 12.12.12.1
!
line con 0
exec-timeout 0 0
logging synchronous
login authentication noacs
line aux 0
login authentication noacs
line vty 0 4
!
R3#sh running-config
!
interface Serial1/0
ip address 23.23.23.3 255.255.255.0
serial restart-delay 0
!
ip route 0.0.0.0 0.0.0.0 23.23.23.2
!
line con 0
line aux 0
line vty 0 4
password cisco
login